A simple Cisco vPC example in N9k

nxos3:

feature interface-vlan
feature lacp
feature vpc

vlan 10
name VPC10

interface Vlan10
no shutdown
no ip redirects
ip address 10.0.0.3/24
no ipv6 redirects

interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 10
vpc 10

interface Ethernet1/1
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/2
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/3
  no switchport
  ip address 34.1.3.0/31
  no shutdown

interface Ethernet1/7
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10

nxos4:

feature interface-vlan
feature lacp
feature vpc

vlan 10
name VPC10

interface Vlan10
no shutdown
no ip redirects
ip address 10.0.0.4/24
no ipv6 redirects

interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 10
vpc 10

interface Ethernet1/1
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/2
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/3
  no switchport
  ip address 34.1.3.1/31
  no shutdown

interface Ethernet1/6
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10

nxos5:

feature interface-vlan
feature lacp

vlan 10
  name VPC10

interface Vlan10
  no shutdown
  ip address 10.0.0.5/24

interface port-channel10
  switchport mode trunk
  switchport trunk allowed vlan 10


interface Ethernet1/6
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10

interface Ethernet1/7
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10